MATLAB: MATLAB R2019b does not use CUDA 10.1

gpu cuda linux r2019bParallel Computing Toolbox

Matlabs seems not to use the correct CUDA driver and throws an error.
MatlabR2019b running on Ubuntu with all the required CUDA toolkits installed throws this error:
>> gpuDevice
Error using gpuDevice (line 26)
CUDA driver version 10 is not supported. Update CUDA driver to version 10.1 or greater. For more information
on GPU support, see GPU Support by Release.
Anyone an idea on how to make Matlab use the cuda-10.1?

Best Answer

  • Run nvidia-smi in a terminal window and see what driver version is reported. It sounds like you have a 10.0 driver and need to update it to 10.1.