Networking – 802.11ac Poor Performance

802.11ac802.11nwireless-networking

I have a relatively simple wireless network setup. The access point is an Asus RT-AC68U which supports 802.11ac. I have two USB wireless adapters: both are Asus USB-AC53's which also support 802.11ac.

  • Computer A is no more than 8 feet away from the access point, through one wall.
  • Computer B is no more than 25 feet away from the access point, through two walls.

These walls are normal: wood, insulation, etc.

  • Computer A will never transmit higher than 100Mbps on 5GHz 802.11ac.
  • Computer B will never transmit higher than 45Mbps on 5GHz 802.11ac.
  • Both computers will easily transmit over 150Mbps on 2.4GHz 802.11n.

Needless to say I've spent a lot of money on this new equipment and would like some advice before I start smashing it.

Yes, I've checked for the security: WPA2-Personal (AES)

I've attempted to adjust channels, channel bandwidth, with no avail.

Best Answer

First, those are terrible 802.11ac client adaptors. They only support 2 spatial streams, which means they could only do the 867Mbps flavor of 802.11ac instead of the 1300Mbps flavor, and also, when doing 802.11n, they can only do the 300Mbps flavor instead of the 450Mbps flavor. And finally, they're only USB 2.0, which means they're limited to USB 2.0's 480Mbps (or less) bus speed.

Second, make sure your AP is set for full transmit power, 80MHz-wide channels, and that you're using a clean 80MHz swath of bandwidth. A tool like inSSIDer will help you figure out where other 5GHz networks are, so you can avoid them. Note that 80MHz channels take up 4 of the traditional 20MHz channels, so if your AP is on channel 36, that means when it uses 80MHz, it's really bonding channels 36, 40, 44, and 48. Even if you change it to channel 48, it'll still be using 36, 40, 44, and 48 when it does 80MHz. If there are other nearby networks on any of those 4 20MHz channels, it will interfere with your 802.11ac.

Here are the 6 5 unique 80MHz channels you can use in North America. I've expressed them as groupings of 4 traditional 20MHz-wide Wi-Fi channels:

 36,  40,  44,  48  
 52,  56,  60,  64 (DFS)  
100, 104, 108, 112 (DFS)  
116, 120, 124, 128 (DFS) Generally not allowed in North America due to possible interference with Terminal Doppler Weather Radar systems near some airports.  
132, 136, 140, 144 (DFS) Only works if your AP and clients support the recently-added channel 144  
149, 153, 157, 161

Note that to use the sets marked "DFS", you may have to leave your AP configured for automatic channel selection. This is because DFS channels can't be used if the AP detects that radar is being used on that channel in your area. So since the AP can't guarantee that it can honor your request to use that channel, it might not let you try to pick it by hand.

Third, try to use the upper non-DFS channel group (149-161) if possible. That upper group usually supports higher transmit power than the lower non-DFS group, so that may help with any range issues.

Fourth, keep legacy rate modes (a/b/g/n) enabled on both bands. Sometimes those legacy modulation schemes are better choices for clients at distance than the newer 802.11ac modulation schemes. You want your clients to have as many choices as possible so they can always pick the best modulation scheme for current radio conditions.

Fifth, don't judge performance by what your OS or Wi-Fi software reports for the data link (PHY) rate. Also, just and important, don't judge performance with your WAN link speeds confusing the issue (that is, don't use an Internet-based speed testing service like Speedtest.net). Run an actual local performance test with something like iperf. Run iperf in client (-c) mode on a wired Ethernet machine on a LAN port of the Wi-Fi AP, and run iperf in server (-s) mode on the wireless machine. IPerf by default sends from the client to the server. So putting the server side on the wireless machine simulates a TCP download to the wireless machine, which is usually what matters most for wireless performance. Make sure both ends of iperf have -w 2M so that you have plenty of TCP window space.

Sixth, use a 1-2 meter USB cable to move your USB 802.11ac adaptor away from the electrical/RF noise of your client rigs. Get it away from both the CPU and the monitor. Try to get it up in the air where it's unobstructed, and away from things like metal desk or file cabinets.

Seventh, make sure you have left WMM (wireless QoS) enabled, and if you're using wireless security, make sure it's WPA2 (AES-CCMP). 802.11ac and 802.11n both require that WMM be enabled, and both require either no security or WPA2 (AES-CCMP). If you disable WMM, or if you only allow WEP or WPA ("WPA1" so to speak; TKIP) security, your clients will be forced to connect at a/b/g rates.

Last, check what RSSI the clients are getting. RSSI is the "Received Signal Strength Indicator". It should be reported in negative dBm. dBm are deciBels relative to 1 milliWatt. The ideal signal strength range is above -60 dBm (rates drop off dramatically as you get to -65, -70, -80 dBm), but below -40 dBm. Some cheaper radios get overloaded if the input power is too strong; -40 dBm or less works for everybody, and a really great radio might still be able to work with signal as strong as 0 dBm. But I see a lot of radios that overload not far above -40 dBm, so I like to do performance tests at -40dBm or slightly lower.