“Acceleration” not available in Intel SRT menu

cacheraidssd

I have an Asus Z68 Motherboard on an existing system running Windows 7 x64. I now want to install an OCZ Agility 3 SSD to make use of the Intel Smart Response Technology. Apparently, it's not an easy task.

To begin with, I installed the latest version of the Intel Rapid Storage Technology from the Asus website. Following these instructions, I then installed the latest BIOS version, changed my SATA mode to RAID and rebooted:

(1) Enter OS, and ensure Intel Smart Response Technology has been
turned off under Intel Rapid Storage Technology interface.

(2) Install
version Intel Rapid Storage Technology driver to version 10.6.0.1002.

(3) Reboot the system, and update BIOS to version 0403, then reboot.

(4) Enter the BIOS setup screen, press F5 to load BIOS default, then
change the Intel SATA Port to RAID mode.

(5) Boot into OS, and
re-enable Intel Smart Response Technology under Intel Rapid Storage
Technology.

This resulted in a blue screen of death, problem being Windows was installed in the default AHCI mode. To prevent this, I rebooted in AHCI to make the following changes to the registry, then returned to RAID mode:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci\Start :: set to 0
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Pciide\Start  :: set to 0
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStorV :: set to 0

(Note: At this stage I don't have a RAID array, just both disks running in a RAID environment, if that's the correct terminology.) All is now well, but when re-enabled Intel RST I still don't see an "Acceleration" tab. Instead in the management tab it just shows both the HDD and SSD are unknown in port and size, only the serial numbers are shown.

Does anyone have any idea how to fix this and set it up properly?

I can't post own answer yet, so:

It looks like I managed to find the cause of the problem. I did reinstall the Intel iRST drivers for a second time earlier in the process, just to ensure they were working, but third time was a charm. It helps when you make the obvious realization I made in my comment regarding the original post.

It looks like a few people have resolved issues by upgrading/reinstalling the driver:
http://www.ocztechnologyforum.com/forum/showthread.php?74090-Intel-Rapid-Storage-Technology-Status-shows-all-drives-0-GB
http://arstechnica.com/civis/viewtopic.php?f=15&t=1151283

Best Answer

  • You could check if the disk is using the Intel driver or the (default) Microsoft one. Go the Device Manager, double click the Controller in question and make sure the used drive is iaStore.

    Device Manager Screenshot