Windows – Accidentally set off mode that ignores keyboard input except to toggle actions, windows

keyboardkeyboard-navigationwindows 7

Every once in a while I seem to accidentally chord something that puts Windows 7 into "be a total PITA" keyboard mode. It seems to be some kind of special keyboard navigation or command mode, where single keypresses will make the UI do things, e.g., D toggles the active window between minimised and unminised. The mouse still works, but I can't use anything that needs text input anymore. This has happened while using several programs, including Minecraft and Firefox. I've been a Windows user for a long time, but I'm not familiar with this behaviour.

Since I have no idea how PITA Command Mode was activated, I don't know how to deactivate it either. Logging off the Windows user and logging back in returns things to normal and is my current solution, but I'd like to just completely disable this behaviour.

I at first assumed it was an accessibility option I'd left un-disabled, but I already have all the accessibility options turned off. I figured it was maybe a feature of my keyboard (MS Wireless Keyboard 3000 v2.0), but I have almost all of the special (media, etc.) keys turned off (in the up-to-date official drive management utility) and none of the ones still enabled jump out at me as possibly having this effect.

I have the Windows, Flip 3D, and Application keys disabled.

Language and keyboard are set to English (Canada) and US (a.k.a. "Qwerty"), respectively.

Best Answer

  • I think the most likely scenario is that your Windows key is getting stuck “on.”

    Certainly if Win+D is pressed, then it minimises windows, so if the Windows key is stuck, then D on its own would do this.

    Usually just hitting the Win again should unstick it.

    The other option is that you have Sticky Keys enabled, and you have "Lock modifier keys when pressed twice in a row" option enabled, and have then pressed the Win key twice to lock it.

    You can enable sticky keys by hitting shift five times in a row, which is easier than it sounds (at least in my experience).

    You can check the status of this by going to

     Control Panel\Ease of Access\Ease of Access Center\Set up Sticky Keys