Ubuntu – After installation of new drivers, Ubuntu won’t boot into graphics mode

kernelnvidia-graphics-cardubuntu-10.04

Here's what I did:
At first I had nvidia drivers from 195 series installed from Ubuntu repositories and everything worked fine. I used system for some time, settled into it and have some data I don't want to lose.

When stable 256 drivers came out, I uninstalled old drivers and installed drivers I downloaded from nvidia. I did this many times on SuSE, so I know how the procedure goes. At first everything was fine. At this moment I should mention that usual uptime for my computer is about 5-6 days. Also I had RGBA Gtk+ module installed for a short while, but I uninstalled it. After couple of weeks, I noticed that I have to rebuild kernel module for nvidia driver after every reboot, because for some reason kernel would load 195 module.

Few days ago, the workaround stopped helping. I uninstalled new drivers, installed 195 and made new xorg.conf. Still, I'd get low-graphics mode and options how to fix it. I tried with various settings in xorg.conf, but nothing could help. I decided to give up and move data to windows partition.

Then I noticed that when I set driver to vesa in xorg.conf, I'd get gdm's log-in screen an after that white rectangle in the center of the screen. After a minute it disappears and I get log-in prompt again. I tried whit various setting, but nothing helped me. I decided to get rid of gdm, so I purged it and switched to KDE. I installed KDE and now after kdm prompt I just get terminal. I can run programs from terminal normally, but the programs don't have the underscore, squares and X to close them. Also, I can only have one program displayed at one time and I can't drag windows.

Any tips on how to solve this issue without formatting Ubuntu partition and doing all from start? Also, I tried purging xorg, drivers and related stuff and installing it all again. It didn't help.

Best Answer

boot as root,then run:

startx

to enter window

Related Question