Windows – Allow incoming remote desktop connection when connected to VPN

networkingremote desktopvpnwindows

Environment: Windows 10, Cisco AnyConnect Client

I have a PC at home. I often connect to it when I am out of the home. However, I have to use a VPN client to get in touch of my servers. And the problem is as soon as I connect to the VPN, my home PC can't accept incoming remote desktop connection because of the network environment has changed.

For now, the only workaround I found is that by install Chrome Remote Desktop, I can use Chrome Remote Desktop to connect the home PC when I am not at home and I have to establish a VPN connection on the home PC.

I am wondering if there is a way to make a hole or some DMZ like config so that I can connect to my home PC through the Windows's built-in RDP service when the home PC is connecting to a VPN?

Thanks.

Best Answer

You probably have not changed the gateway settings for the VPN.

By default, once you make a VPN connection, all network traffic is routed through the VPN. This ensures DNS remains working, but is not necessary.

By disabling use default gateway on remote network, your internal network remains active.

I'm not entirely sure how to change this in the Cisco AnyConnect client though, but I'll write the change for regular VPN, so it might help you find the setting on your Cisco AnyConnect client.

Go to Control Panel -> Network Center -> Adapter settings -> VPN Connection

Right click the connection and choose Properties.

Access the tab Networking Doubleclick the TCP-IP v4

Press Advanced

Uncheck Use default gateway on remote network