Macos – Apple Mail doesn’t apply rules unless I choose “Apply Rules” manually

apple-mailemailemail-filterimapmacos

I'm using Apple Mail with IMAP account. I have several filtering rules defined. The problem is that Mail doesn't apply them automatically to incoming email. Even spam isn't filtered automatically.

For all incoming email, every time, I have to select e-mails and select "Apply Rules", and then rules work fine (that one time on selected e-mails only).

It works like this on two separate installs of Mail with different accounts (both IMAP though).

How can I get Mail to apply all rules automatically every time to all e-mails?

I wonder does it ignore rules because of misconfiguation, bug or does Apple seriously expect people to use "Apply Rules" menu item regularly?

Best Answer

This is a bug.

In their infinite wisdom, Mail.app developers decided only to apply rules to 'unseen' messages. If the IMAP 'seen' flag is set, rules will not be applied.

I started a forum thread on the apple forums on this topic.

Related Question