Cannot stop the computer from going into the BIOS automatically

asus-laptopbiosboot

I bought a laptop ASUS PU500CA with FreeDOS installed.
First time when I turned it on I got a FreeDOS command line. I tried to run dir to check that everything is all right. It returned a list o files. It seemed that everything was all right…

Then I installed Ubuntu 14.04.
After that when I am rebooting I see only BIOS blue screen.

In a boot tab there is only such information:

Boot configuration
Launch PXE OpROM disbaled

There is no an option of booting with HDD.

But in the Advanced tab there is info about HDD (Hitachi…)
When I push ESC or F10 to exit from BIOS It enters BIOS again and again…

What is this?

PS: I forgot to say that

Boot Option Properties

in tab Boot is unavailable for choosing.

Best Answer

I have had the same issue..hit much website for solution but there was no problem with my CMOS battery, stuck keyboard,HDD,ram etc. I just turned off my main switch and then turn it on.....everything is fine now and windows boots appropriately.

I inserted every USB device like mouse keyboard and sound cords as they were in before and my windows keep booting properly as before but after the American Megatrend problems! I

know that many things could make it no working but by this event I have just realised - sometimes you have to take risky decision and turn off the main power plug!

Oh one event was the culprit I guess ... Today I installed a driver toolkit software. It might cause the problem though i uninstalled it before shutting down the PC due to the fake service of this software!