Can’t connect MySql to, only to localhost


I have a portable version of a MySQL database that I'm trying to connect to.

On a computer running on Windows 10, I can connect to it using at port 3310.

If I copy that instance to any other computer running Windows 10, I can connect using the IP.

When I copy that same instance to a Windows Server 2016 VPS, I cannot connect to the database using the IP address, it only connects if I use localhost.

I need to connect using the IP address. Some people told me that I should have a problem with my hosts file, but it's exactly the same on both computers.

Does anyone have an idea of what could be causing this?

— UPDATE 1 —

I know there localhost and are almost the same. But the problem for me is that I use a legacy software that only accepts the IP address, that's why I can't use localhost.

I wasn't able to connect the software to the database, then I installed HeidiSQL and tried to connect using and it really wasn't working, so I changed to localhost and it connected.

Since I can't change the legacy sofware to use localhost, I need to figure out why MySQL is not accepting connections through

— UPDATE 2 —

Here's the SQL configuration file:

    # Example MariaDB config file for large systems.
    # This is for a large system with memory = 512M where the system runs mainly
    # MariaDB.
    # MariaDB programs look for option files in a set of
    # locations which depend on the deployment platform.
    # You can copy this option file to one of those
    # locations. For information about these locations, do:
    # 'my_print_defaults --help' and see what is printed under
    # Default options are read from the following files in the given order:
    # More information at:
    # In this file, you can use all long options that a program supports.
    # If you want to know which options a program supports, run the program
    # with the "--help" option.

    # The following options will be passed to all MariaDB clients
    #password   = your_password
    port        = 3310
    socket      = /tmp/mysql.sock

    # Here follows entries for some specific programs

    # The MariaDB server
    port        = 3310
    socket      = /tmp/mysql.sock
    key_buffer_size = 256M
    max_allowed_packet = 256M
    table_open_cache = 256
    sort_buffer_size = 1M
    read_buffer_size = 1M
    read_rnd_buffer_size = 4M
    myisam_sort_buffer_size = 64M
    thread_cache_size = 8
    query_cache_size= 16M
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 8

    # Point the following paths to different dedicated disks
    #tmpdir     = /tmp/

    # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    # if all processes that need to connect to mysqld run on the same host.
    # All interaction with mysqld must be made via Unix sockets or named pipes.
    # Note that using this option without enabling named pipes on Windows
    # (via the "enable-named-pipe" option) will render mysqld useless!

    # Replication Master Server (default)
    # binary logging is required for replication

    # binary logging format - mixed recommended

    # required unique id between 1 and 2^32 - 1
    # defaults to 1 if master-host is not set
    # but will not function as a master if omitted
    server-id   = 1

    # Replication Slave (comment out master section to use this)
    # To configure this host as a replication slave, you can choose between
    # two methods :
    # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    #    the syntax is:
    #    MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    #    where you replace <host>, <user>, <password> by quoted strings and
    #    <port> by the master's port number (3306 by default).
    #    Example:
    #    CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    #    MASTER_USER='joe', MASTER_PASSWORD='secret';
    # OR
    # 2) Set the variables below. However, in case you choose this method, then
    #    start replication for the first time (even unsuccessfully, for example
    #    if you mistyped the password in master-password and the slave fails to
    #    connect), the slave will create a file, and any later
    #    change in this file to the variables' values below will be ignored and
    #    overridden by the content of the file, unless you shutdown
    #    the slave server, delete and restart the slaver server.
    #    For that reason, you may want to leave the lines below untouched
    #    (commented) and instead use CHANGE MASTER TO (see above)
    # required unique id between 2 and 2^32 - 1
    # (and different from the master)
    # defaults to 2 if master-host is set
    # but will not function as a slave if omitted
    #server-id       = 2
    # The replication master for this slave - required
    #master-host     =   <hostname>
    # The username the slave will use for authentication when connecting
    # to the master - required
    #master-user     =   <username>
    # The password the slave will authenticate with when connecting to
    # the master - required
    #master-password =   <password>
    # The port the master is listening on.
    # optional - defaults to 3306
    #master-port     =  <port>
    # binary logging - not required for slaves, but recommended

    # Uncomment the following if you are using InnoDB tables
    #innodb_data_home_dir = C:\\mysql\\data\\
    #innodb_data_file_path = ibdata1:10M:autoextend
    #innodb_log_group_home_dir = C:\\mysql\\data\\
    # You can set .._buffer_pool_size up to 50 - 80 %
    # of RAM but beware of setting memory usage too high
    #innodb_buffer_pool_size = 256M
    #innodb_additional_mem_pool_size = 20M
    # Set .._log_file_size to 25 % of buffer pool size
    #innodb_log_file_size = 64M
    #innodb_log_buffer_size = 8M
    #innodb_flush_log_at_trx_commit = 1
    #innodb_lock_wait_timeout = 50

    max_allowed_packet = 256M

    # Remove the next comment character if you are not familiar with SQL

    key_buffer_size = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M


Best Answer

By default, mysql/mariadb server config is to only listen on localhost ( To allow remote connections, you have to bind to a real IP address. You can specify a specific IP to restrict things. Alternatively, you can bind to all IPs by commenting out this line:

#bind-address = <some ip-address>

You posted your config, and I did not see this line, but make sure you don't have a bind-address line anywhere in your config.

Also ensure you are not skipping the network config. You want this line commented out:


Documentation about allowing remote access that explains this in more details is here:

You also need to create a user who is allowed to connect from either all hosts or the specific host(s) or network(s) you will connect from. See the mariadb documentation link above for details about creating users who can connect from remote hosts. For example, to create a "bloguser" user that has all privs for all tables in your "myblog" database and can connect from any remote host:

GRANT ALL PRIVILEGES ON myblog.* TO 'bloguser'@'%' IDENTIFIED BY 'bloguser-password';

Of course your networking config needs to allow port 3306 (or your custom port if changed) access to your database through any firewalls you may have. You can test basic network access from a remote host using telnet. Let assume your database server IP is At the command line on the remote machine, try:

telnet 3306

Wait for things to succeed, fail, or time out. Here are some results you might see and potentially what they mean:

  1. "Connected to" SUCCESS!
  2. "Unable to connect to remote host: Connection timed out" You have a route, but not getting through. Could be firewall on the server not allowing 3306. Could be your own network not allowing 3306 outbound.
  3. "Unable to connect to remote host: No route to host" Your system does not even know how to get to that network.
  4. "Unable to connect to remote host: Connection refused" A common reason for this is that mariadb is not running or is not listening on that IP and port. (bound to for example). It could be that a firewall refused the connection.