Windows – Can’t disable windows 10 PIN complexity

gpeditgroup-policypinwindows 10

I recently linked my Microsoft Office account to my school to have access to Office for students. Right after linking my account, I couldn't login to my computer again with my 4-digit pin code and got the message: "your organization has set the following pin code requirements. Your pincode has to be at least 6 digits long."

I had to change my pincode but I want to change it back to my original 4-digit one. Some internet research has made me enable gpedit.msc, but when I try to find the PIN complexity setting in gpedit (Computer Configuration\Administrative Templates\System\PIN Complexity) it just isnt't there.
enter image description here

Another possible path in gpedit I found on the internet to do this was: Computer Configuration > Administrative Templates > Windows Components > Windows Hello for Business > PIN Complexity, but that also didn't work as I don't have "Windows Hello for Business"

I also tried resetting my computer to the date before I joined my 'organization', but that didn't work either.

Does anyone have an idea how I can resolve this issue?

Best Answer

Try to remove the PIN option completely and then re-add it.

Go to Settings > Accounts > Sign in Options, and under PIN select "I forgot my PIN". Enter your password, and when asked to enter a new PIN, select Cancel.

Then go about re-adding your PIN. It might let you add a 4 digit PIN this time.

If this does not work, you will need to uncouple your account from the school.