Centos – phpMyAdmin No activity within 1440 seconds; please log in again. Issue

centosPHPphpmyadminsession

I have installed latest phpMyAdmin on Apache+php+mysql on CentOs.

But after sometime of inactivity i am getting

No activity within 1440 seconds; please log in again.

And redirected to the phpMyAdmin Log-In page.

I have Edited /etc/php.ini
and set

session.gc_maxlifetime 999999

and did HTTPD restart.

But still i am getting the same error.
How do i fix this ?

How do i make the phpMyAdmin session for like 20+ days, as its a production environment.

Thanks

===========================================================================================

my phpinfo session is as

Session Support     enabled
Registered save handlers    files user
Registered serializer handlers  php php_binary wddx

Directive   Local Value Master Value
session.auto_start  Off Off
session.bug_compat_42   Off Off
session.bug_compat_warn Off Off
session.cache_expire    180 180
session.cache_limiter   nocache nocache
session.cookie_domain   no value    no value
session.cookie_httponly Off Off
session.cookie_lifetime 0   0
session.cookie_path /   /
session.cookie_secure   Off Off
session.entropy_file    no value    no value
session.entropy_length  0   0
session.gc_divisor  1000    1000
session.gc_maxlifetime  999999  999999
session.gc_probability  1   1
session.hash_bits_per_character 5   5
session.hash_function   0   0
session.name    PHPSESSID   PHPSESSID
session.referer_check   no value    no value
session.save_handler    files   files
session.save_path   /var/lib/php/session    /var/lib/php/session
session.serialize_handler   php php
session.use_cookies On  On
session.use_only_cookies    On  On
session.use_trans_sid   0   0

Best Answer

The same problem has been annoying me for weeks, but I think that I now have the answer, at least for the latest versions of phpMyAdmin (I currently have version 4.1.14). You need to change settings->features->Login cookie validity. The way that you get to this setting is as follows:

1) Login to phpMyAdmin
2) From the home screen click on "More settings" (middle bottom of screen for me)
3) Click the "Features" tab/button towards the top of the screen.
4) For 20 days set the "Login cookie validity" setting to 1728000
5) Apply.

Hope that helps?