Linux – “chmod” doesn’t work

chmodlinux

I wrote a /bash script and to execute it I decided to set all the rights, so I tried

chmod 777 * //I had 3 text files in the directory, so that's ok

Then to check the result I typed

ls -l

But the rights hadn't changed at all.

I haven't got any error messages and it seems strange. I also tried to specify full path, but this hadn't helped.

I also tried to do all of these steps under root

Where may be the problem?


Thank you for help!


ls -la

drwx------ 1 gemma gemma 4096 июля  20 18:00 .
drwx------ 1 gemma gemma 4096 июля  20 16:35 ..
-rw------- 1 gemma gemma  407 июля  20 18:00 buildedfile.out   ;this is what I
                                                               ;need to launch
-rw------- 1 gemma gemma 4096 июля  20 17:21 kernel.bin
-rw------- 1 gemma gemma  350 июля  20 16:59 link.ld
-rw------- 1 gemma gemma 2025 июля  20 17:59 main.c
-rw------- 1 gemma gemma 1894 июля  20 17:34 start.asm
-rw------- 1 gemma gemma  457 июля  20 17:20 start.o

That is what ls shows after all I tried


I rebooted PC and problem rose again. But now any of suggested methods doesn't help.


I'm using Linux Mint 13 32-bit.
On main disk where this files are located I have ext3, also tried on two another partitions where I have ntfs and FAT32.


buildedfile.out is a terminal app written on C

Best Answer

I had this same problem, the partition I was accessing was an ntfs partition mounted with ntfs-3g (with no permission support by default), and it took a while for me to remember that.

I would expect chmod to give me some warning, but it didn't just like in your case.

I know there is an option on fstab when using ntfs-3g to make it possible to set permissions in an ntfs partition as described here.

I hope it helps.

Related Question