Windows – Connection Settings in IE changes after every system restart

internet explorernetworkingPROXYwindows 7

I changed the settings in IE to not to use proxy server for connections by unchecking the

Tools->Internet Options->Connections tab->Settings->Use a proxy server for this connection

But Whenever I restart my windows 7, Internet Explorer changes its setting back again to use the proxy server settings. So in other browsers such as Firefox or Chrome some website are not loading and shows a page which shows only the message Error.

So I need to uncheck the checkbox every time I restart my Computer.
And my Eclipse software does not connects to the internet to download the neccessay files to start my jetty server. So I need to disconnect the internet and wait for the server to start after throwing some error message about connection problem and I have to reconnect the internet connection to use it back again.

So how do I set a global setting in Windows 7 to apply to all application to not use a proxy while connecting to Internet.?Or How to bypass the Internet Explorer connection settings and tell a software application to use its own internet connection setting and not the one mentioned in my IE browser?

Best Answer

Use the registry key:

HKLM\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings

to set the binding of:

ProxySettingsPerUser

to:

1

in order to persist your settings.

In addition, set:

ProxyEnable

to 0.

As an alternative, add a list of sites to the Internet Zone which bypasses the proxy as a workaround:

  • Internet Options => Security => Local Intranet
  • Click Advanced
  • Put a site you access in the text field, such as:

    *://*.superuser.com
    
  • Click Add
  • Repeat for others, such as:

    *://*.stackoverflow.com
    *://*.stackexchange.com
    

Or create a script to generate the list and append it to the following file:

file://c:/windows/system32/drivers/etc/proxy

References