Windows – Disable auto-refresh tabs in Chrome Desktop

browserdesktopgoogle-chromewindows

Since a recent update in Chrome (Windows, desktop) if I change to some tabs, which haven't been opened for a longer time, Chrome automatically performs a refresh on the page. It only happens, when the tab hasn't been opened for a longer time.

It's really disturbing for me, and haven't found any solution to disable this.
Anyone knows, how to disable this?

Thanks!

Best Answer

The OP is right. This has started happening in the latest release (Chrome Stable Version 48). I was also going bonkers due to this new 'feature' and then I did some research. It is not due to any extension as another user has suggested. It's a relatively new parameter which has been turned ON by default in the new release. Chrome Team is calling it "Tab Discarding". This may happen if there are many Tabs open and Chrome is running out of Memory. According to their documentation, "Tabs are now sorted from most interesting to least interesting. The least interesting tab may be discarded if we run out of physical memory." I suppose least interesting would translate to those tabs which weren't accessed in a while.

Though they are trying to help us free some RAM, however, this 'feature' totally ruins the tab if you don't want its contents to refresh due to some reason, like a YouTube video you paused at a particular location. Or wanted to go back to some top headlines on the homepage of CNN, which you had glanced at earlier and now you want to go back to them, but as soon as you click the tab, this 'feature' auto refreshes the page, updating the headlines. List goes on and on. I also had some Amazon tabs open and had specifically wanted not to have the page update, because it had some particular images and design elements displayed that I wanted to refer later, but when I got back to those pages, the 'Tab-discarding' feature 'auto refreshed' all of them, replacing them with the current version of the pages, totally devoid of whatever I wanted to refer to. And for those who suggest it is probably Amazon's auto-refresh, no, Amazon doesn't auto-refresh product pages, I have had pages remain open for many days and they would never update unless I clicked Refresh.

Now, let's get back to the Solution

To see the 'Discarded Tabs', type this in the Address Bar: chrome://discards/

To actually disable:, type in your address bar: chrome://flags, then disable this flag: #automatic-tab-discarding (Turn it to 'Disabled' from 'Default')

Simple solution to a highly unproductive and frustrating issue. That's it. You can stop pulling your hair out now :)

Source: Google Product Forums

Chrome 63+

In more recent versions of Chrome the #automatic-tab-discarding flag is removed, however, you can still toggle auto discard for chrome desktop apps on the chrome://discards/ page.