Chrome – Disable “Ctrl”+mouse wheel zooming in Chrome

google-chromemouse-wheelzoom

I'm a normal-sighted person and I would like to view pages at 100% all the time. I use keyboard shortcuts that involve Ctrl a lot, so about twenty times a day I accidentally hit Ctrl at the same time that I'm scrolling, which results in the page being reflowed and repainted. This is annoying because it can take up to 30 seconds to fix the issue, depending on how complex the site layout is. On sites with dynamic layout such as Google Docs the problem is more serious; accidentally hitting Ctrl+mouse wheel corrupts the display and forces me to refresh the page entirely, sometimes causing me to loose information in the process.

I would like to either decouple Ctrl+mouse wheel from zoom, or disable zoom functionality altogether. This is possible on Firefox by using about:config; is there a similar way to edit detailed settings in Chrome? Would I have access to the detailed settings if I used Chromium instead of Chrome? I'll probably jump ship back to Firefox if I can't solve this problem.

There is a superuser question that asks basically the same thing I'm asking, but for Firefox and Internet Explorer exclusively. Other people on the Chrome forum have had related issues, but none have the same problem. "I would really like it if I could deactivate the auto zoom in/out." had "something with laptops and Windows 7", not the feature built into Chrome. Other people have had PDF specific issues, which doesn't concern me.

I've also tried searching for extensions that allow you to disable the scroll; I had hoped that "Zoom Lock" would have the ability to lock the zoom at 100% and prevent Ctrl+scroll wheel from distorting the display, but it doesn't work for my use case.

I am using Google Chrome (version 9.0.597.84 (Official Build 72991)) on Ubuntu 10.10.

Best Answer

  • There is a solution using AutoHotKey posted on google groups:

    Using Logitech Performance Mouse MX...

    Downloaded AutoHotKey software

    In the AutoHotkey.ahk file, added these to do nothing for Cntrl+MouseWheelScrolling

    ^WheelDown::return
    
    ^WheelUp::return
    
  • Related Question