Windows – Disable the low disk space popup warning in windows 10

disk-managementhard driveramdiskwindows 10

How can I disable Windows 10's low disk space warning?

Background:

I have set up a RAM disk as a kind of swap file for Nvidia's Instant Replay (which writes about 1.5GB of video every five minutes). (This function used to be called ShadowPlay.)

It works great except that Windows keeps warning me about low disk space on this drive:

low disk space

"Low Disk Space You are running out of disk space on RAMDISK (Z:). Click here to see if you can free space on this drive."

It is not actually running out of space, as saving the replays is working correctly. I assume Nvidia's software is a bit lazy about deleting its temporary files.

Best Answer

To disable these balloon messages follow the steps below:

  1. Open the Registry Editor by clicking on Start -> Run and running REGEDIT.

  2. Navigate to the following location:

HKEY_CURRENT_USER\Software\Microsoft\ Windows\CurrentVersion\Policies\Explorer

  1. Right-click in the blank area of the right-hand pane of the Registry Editor and create a new DWORD Value by selecting New -> DWORD Value.

  2. Name this new DWORD Value NoLowDiscSpaceChecks

  3. Double-click on the new DWORD value and assign it a value of 1.

  4. Close the Registry Editor and restart the computer.

For more information on this refer this Microsoft page