Disable touch pad for mouse button region on new HP pavillion models

mousemouse-buttonstouchpad

i bought a new hp pavillion dv6 series laptop. the laptop itself is fine but it has the new hp touchpad mouse which i absolutely hate. its such a stupid problem to have with a computer. the left and right mouse buttons are, themselves, part of of the touchpad, meaning that if i tap the buttons without actually pressing them down, it registers the same way as the mouse pad (the cursor moves, tap to click activates, etc.) .

This is a major annoyance because it prevents you from operating the mouse pad with anything more than a single finger; if for example I use my right hand index finger to move the cursor using the touch pad and rest my left hand index finger on the left mouse button for more efficient mouse-ing, the mouse will react as if im trying to use 2 fingers to move it and it will either just sit there or will spaz out. the only way this works is if i keep the finger that is resting on the mouse button absolutely still, which is very difficult and, therefore, very annoying.

Also, even if i do abide by the arbitrary new decree of single-finger mousepad operation, i still have a problem because when i press down on the left or right click buttons, the mouse moves slightly, what with the buttons also being part of the touch pad and all. this would not be that hard to avoid except that they decided to also make the buttons much harder to press down. now whenever i go to click something, i press hard on the mouse button, causing my finger to slightly move or roll or flatten out a bit, causing the cursor to move slightly, and causing me to click on something different.

what i would like to know is if there is anyway that i can disable the touch pad on the buttons. i have gone through all of the settings under the synaptics menus but i cannot find anything about this. did i miss something in one of the menus? if not, then are there any updated drivers that allow for toggling of this function?

Best Answer

I have a DV7T and hate the clickpad too. I have searched for a windows driver with the ability to disable this section with no luck, so I thought of a mechanical way to block the bottom section of the touch pad. I taped a piece of silicone from a blackberry cell phone skin to the bottom of the clickpad. It is not pretty at the moment, but this is my first attempt and it seems to be working. I will be looking into other thinner materials that don't ativate the clickpad. I will post an update if I find somehting better.