Linux – Disable Windows Key hotkeys when using Virtualbox

arch linuxemacshotkeysvirtualboxwindows 7

I'm currently running a VirtualBox of Arch Linux with Windows 7 x64 as the host. In Arch, I use dwm for window management. As dwm is heavily dependent on hotkeys, I've used the Alt key as its META key to prevent conflict with the Windows 7 host. However, when using Emacs (also heavy hotkey usage) within dwm, there are issues because it's also using Alt for its own META.

I'd like to change either dwm or Emacs to use the windows key as META, but commands such as Win+L will be captured by the host machine and lock my system. Is there any way to prevent these hotkeys from being triggered while within VirtualBox?

Best Answer

I had the same problem (Linux guest in Windows host with wmii windows manager). This registry hack works perfectly.

Open up regedit.exe through the start menu search box, and then browse down to the following key, creating it if it doesn’t exist:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System

On the right-hand side, create a new DWORD 32-bit value named DisableLockWorkstation and give it one of these values:

• 1 – Disable Lock Workstation
• 0 – Enable Lock Workstation

The changes should be immediate, no need to restart anything.