Why does GIMP start up so slow on the machine

bootgimpperformance

Is there any way to speed up GIMP's startup time on Windows Vista Home Premium 32-Bit 1.6 [Dual] Intel Processors? On XP [different computer], it loads in less than 3 seconds. On Vista, it takes 20 seconds:

  • 2 Seconds (other – fonts, brushes,
    etc)
  • 18 Seconds (extension-script-fu)

It just freezes at extension-script-fu. Looking at Process Explorer, I see that it's not taking any CPU at all. EDIT 1: It does seem to be taking 50% of the CPU.

It gets stuck for about 18 seconds, and then starts working again. Then, the actual GIMP program pops up […finally]. I have the latest stable version running (I think). I tried it with XP SP2 Compatibiliy mode and/or Run As Administrator, but that didn't help.

EDIT 2: One way would be to disable script-fu. Does anyone know how to disable it at startup? Is it possible? Would GIMP still work? What wouldn't work? Could I start it later, after loading?


EDIT 3: Seems to startup at lightning speeds even with script-fu (<3 seconds) in GIMP 2.8 RC1 on Windows Vista.

Best Answer

If this happens to you when the splash screen gets to "Loading Data Files - Fonts", then there are several workarounds to this slowdown.

To analyze the slowdown, you may add the --verbose parameter to GIMP to better analyze startup problems.


The article Slow GIMP startup : Graphics advises :

This used to happen to me too. Some kind-soul told me that there in the c:\documents and settings\user-name\ directory, there will be a ..fonts-cache1 file. Delete that cache and re-start GIMP. First time it takes a while to make that fonts-cache again, but from 2nd time it should be pretty normal.

Note that on newer systems (Windows 7 & 10) this folder moved to C:\Users\<username>\AppData\Local\fontconfig. A quick way to get there is typing: Win+r, and entering %appdata%/../local/fontconfig (or write the same in the address line of a file-explorer window).


Another advise is :

I created a shortcut with the command parameter --no-fonts and it started very quickly.


The GIMP FAQ says :

The GIMP takes too long to load - how can I speed it up?

The main things are to make sure you are running at least version 1.0, and make sure you compiled with optimization on, debugging turned off, and the shared memory and X shared memory options tuned on.

Or, buy a faster system with more memory. 8^)

If it's still too slow for you, the easiest speedup is to invoke the GIMP with the "--no-data" option. This prevents the GIMP from loading patterns, brushes, and similar resources when it starts. You may benefit slightly from the "--no-splash" option as well; you might want to time that one to see if it really helps enough to be worthwhile.


If the problem lies in one or more extensions, the only solution is to uninstall these extensions. The extensions are found in the folder GIMP is installed in (usually Program Files), inside C:\Program Files\GIMP-2.0\lib\gimp\<version>\plug-ins. Just rename the extension file to .old or something, for example script-fu.exe to script-fu.exe.old. The easiest way to get rid of all the extensions is to rename the entire plug-ins folder.