Windows – Does Windows 10 support UTC as BIOS time

utcwindows 10

EDIT 2015-SEP-30:

Seems I actually ended up with localtime enabled in Linux somehow, probably as a consequence of a reinstall some time ago. I switched Linux to UTC and now my configuration seems to be working fine.


Related to Does Windows 7 support UTC as BIOS time? and Does Windows 8 support UTC as BIOS time?, does Windows 10?

I've successfully used the method recommended in those two questions in the past with Windows 7 but it doesn't seem to be working with Windows 10. I believe I had the same problem with Windows 8.1. I'm not sure about Windows 8.

I've tried a multitude of different configurations for date/time settings (from right clicking the clock and selecting "Adjust Date/Time). My current configuration is:

Set time automatically: On

Time Zone: (UTC-05:00) Eastern Time (US & Canada)

Adjust for daylight saving time automatically: On

I've also tried instructing it not to set time automatically (which I think I may have done in Windows 7?) and not adjusting for daylight savings time.

I've tried setting the registry value (from the linked questions) to a QWORD instead as recommended in https://wiki.archlinux.org/index.php/System_time#UTC_in_Windows but it still had no effect.

Has anyone had any success in using UTC time in Windows 10 and if so was it necessary to do anything differently compared to Windows 7?

Best Answer

Yep, I had success. Don't forget disabling the "internet update" for the time!

I used the way described in the ArchWiki using a QWORD on a 64bit Win10. The NTP is done on Arch and not on Windows, but the latter isnt getting booted so often anyway.

Here's the .reg file:

RealTimeIsUniversal.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=hex(b):01,00,00,00,00,00,00,00

From ArchWiki: UTC in Windows

Using regedit, add a DWORD value with hexadecimal value 1 to the registry:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\RealTimeIsUniversal

Alternatively, create a *.reg file (on the desktop) with the following content and double-click it to import it into registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
 "RealTimeIsUniversal"=dword:00000001

If the above appears to have no affect, and a 64-bit variant of Windows is being used, using a QWORD value instead of a DWORD value may resolve the issue.