Windows – Endless Security Certificate Errors

internet-explorer-8windows 7

Recently Internet Explorer 8 has started displaying the information bar on almost every web site I visit, with the following message:

To help protect your security, Internet Explorer has blocked this website from displaying content with security certificate errors.

So far none of the pages I'm visiting are even using SSL. I've tried the following suggestions from various web sites to no avail:

  • check the system date and time – already set correctly
  • reinstall latest root certificates update – done
  • disable check for certificate revocation – done
  • delete expired certificates – could only delete one

This is frustrating to the point where I'm having to use another browser, but I can't accept that it's not fixable. I'm using Microsoft Security Essentials if that matters.

Best Answer

You may want to try resetting Internet Explorer's settings to their default state.

You can do this by going to Tools and then opening the Internet Options window. Go to the Advanced tab and click the Reset... button, and then click Reset in the window that pops up. Once this is done, close Internet Explorer and reopen it, and see if this fixes your problem.

For more information on which settings are changed, or to see a video walkthrough, check out Microsoft KB 923737, How to reset Internet Explorer settings