Excel 2010 Pivot Formatting – Can’t indent and wrap fields

microsoft-excel-2010pivot table

When working with pivot tables in Excel 2010, I want to show my pivot in compact form, with each field being indented as you move through the data, like so:

basic pivot structure

However, some of my data strings are actually very long, and this significantly reduces the readability of the pivot, as seen here:

really long data

To correct, I thought I could simply resize the rows and wrap the text, but this causes the indentation to be removed automatically, like this:

no more indent

I've tried playing around with the few options I can think of to make this work. I can manually indent each field after wrapping, but any time the data is refreshed, this gets funky, with or without preserving formatting.

Is there a simple way I can make this work? Am I just stuck with one option (indentation) or the other (wrapping)?

Best Answer

  • Okay, yes this is possible! Sounds like a job for pivot table!

    First things first, go to your Pivot Table Tools - Options - Actions - Select and make sure Enable Selection is enabled.

    Next, go into your pivot table. When you move between fields you'll have a white plus sign type cursor and sometimes you'll get a black down arrow. When you get the arrow above the field you want to wrap, you click and it will select that Field.

    Now, go to Home - Alignment - Wrap Text and it will wrap that field without getting rid of the pivot table structure.

    enter image description here

  • Related Question