Excel – How to stop Excel (2007) from copying hidden cells

copy/pastemicrosoft excelmicrosoft-excel-2007

Let's say I have some rows or columns that are hidden, and drag a selection across where those hidden values would normally be. Is there a way to prevent Microsoft Excel from copying those hidden cells?

I've found a workaround that sometimes works by pasting it all into Notepad, and then copying that, then pasting it into the spreadsheet I want to paste those values into, but it seems there should be a better way to do that. Unfortunately this workaround doesn't always work so well.

Best Answer

From Copy visible cells only:

If some cells, rows, or columns on your worksheet are not displayed, you have the option of copying all cells or only the visible cells. By default, Excel copies hidden or filtered cells in addition to visible cells. If this is not what you want, follow the steps in this article to copy visible cells only. For example, you can choose to copy only the displayed summary data on an outlined worksheet.

  • Select the cells that you want to copy.
  • On the Home tab, in the Editing group, click Find & Select, and then click Go To.
  • In the Go To dialog box, click Special.
  • Under Select, click Visible cells only, and then click OK.
  • On the Home tab, in the Clipboard group, click Copy.
  • Select the upper-left cell of the paste area.

    Tip: To move or copy a selection to a different worksheet or workbook, click another worksheet tab or switch to another workbook, and then select the upper-left cell of the paste area.

  • On the Home tab, in the Clipboard group, click Paste.

Notes

Excel pastes the copied data into consecutive rows or columns. If the paste area contains hidden rows or columns, you might need to unhide the paste area to see all of the copied cells.
If you click the arrow below Paste, you can choose from several paste options to apply to your selection.