Linux – file permissions – correct ntfs mount option

linuxmountntfsntfs-3gpermissions

I want to mount my NTFS partition to have the same permission as my files and folders in Linux. I have the current mount options:

UUID=4C4EF1264EF1098A /run/media/user/FILES ntfs-3g defaults,exec,permissions,inherit,uid=1000,gid=1000,dmask=022,fmask=133 0 0

The problem is, I was not able to execute anything on that partition. What should I be using?

Best Answer

It's about fmask=133. The digit 1 applies to the owner's permissions and masks x permission, so no file will be executable.

This answer is useful (it talks about vfat but umask, fmask and dmask mechanism is the same). From therein:

It works as the normal octal permissions but subtracted from 7, and use the absolute value. for instance if you want to set the permissions to 0777 you will need to set it 0000 in the umask (e.g. umask=0000), if you want to set it to 0755 you will set it to 0022.

fmask=133 sets files permissions to 644. Use fmask=022 or fmask=033. I think the last two digits shouldn't really matter because ntfs-3g is FUSE-based and as such it makes the filesystem available only to the owner (specified by uid=), unless you configure and use allow_other option.