Google-chrome – Google Chrome background tabs don’t load/build until selected

google-chrome

When browsing, I tend to middle-click things I want to read so they load in a new tab in the background. That way they're ready to read when I finish the current page.

Recently the behavior changed in Google Chrome. Now when I select a background-loaded tab, my disk chugs for a long time instead of switching instantly. It doesn't actually build the background tab until I select it. And it takes longer for it to foreground it than it would have to just load it. (Note, I believe the page was downloaded from the internet, just not "imaged", since the disk chugs like it was paged out and it's not displaying the usual progress in the status bar at the bottom.)

What changed? How do I get the old behavior back?

Google Chrome: 35.0.1916.153 (Official Build 274914) m

OS: Windows

(I've googled for chrome, background tab, lazy load, delayed load, etc… no luck with any search terms after about an hour.)

EDIT: This recently stopped happening on all my computers within a one-week period. It looks to me that it was a change implemented in Chrome, again.

Best Answer

INT_541 had the right answer above. Out of all the sites I checked, his was the only one that worked for me. I disabled the setting below and tabs started functioning like before (loading in the background). Without it, even tabs I had viewed would get unloaded until I viewed them again. It is nice to have this option if your bandwidth and PC can handle it.

chrome://flags/#enable-offline-auto-reload-visible-only