Google-chrome – Chrome slow opening file upload on network path

google-chromenetwork-shares

I'm getting different behaviors in Chrome vs. Firefox and IE, when trying to upload a file from the same web page.

The first time I click browse, the file open dialog opens immediately. I upload my first file. The second time, on Chrome, it hangs for about 5-10 minutes before opening the dialog, while on Firefox and IE, it is always immediate.

This only happens on network paths. If I switch the path to a local drive, it opens immediately, every time, on every browser.

This is reproducible at will, and occurs 100% of the time.

What is the cause of this and/or how do I fix?

Best Answer

The thread Why is the first download slow to open dialog box? discusses a similar problem :

The problem occurs, I think, because Chrome has stored a previous save-to location that no longer exists (such as one on a network drive). I was able to prove this by looking through the samba logs on our old server (which no longer had a shared volume) and I saw repeated attempts to access the old shared volume every time I attempted to save something with Chrome.

The delay was manageable until the old server itself was removed from our network, then the delays stretched to almost a full minute or more. (The delays were less when the server was still active, because the server presumably told Chrome that there was no such storage location. But once the server itself was gone, Chrome would wait for an inordinately long timeout on the first "save" of each browsing session.)

A solution that worked for one person was :

  1. Within Chrome, Click the Customize icon in the upper right. Choose Bookmarks/Bookmark Manager/Organize.
  2. Export your bookmarks to an HTML file -- somewhere you can find it.
  3. Close Chrome.
  4. Go to
    C:\Documents and Settings\<username>\Local Settings\Application Data\Google\Chrome\User Data
    (fill in your user name)
  5. Right click on the User Data folder and rename it. I just add an X to the end of the name.
  6. Restart Chrome, go to Bookmark Manager and import the bookmarks

Another workaround : Running CCleaner to clean the registry has helped another guy.