Chrome – Google Chrome doesn’t delete the browsing history correctly

firefoxgoogle-chromehistory

I have deleted everything that I could from my browser history:

chrome://settings/clearBrowserData

I checked everything and select the begining of time

Then when I access browsing history:

chrome://history/

There is nothing (as I expected), or to be precise No history entries found.

The problem is that I still see my specific search url with very specific query I have made a month ago, when I start typing the url of the website into chrome address bar.

How is that possible? Where is Google stroing these data. How to get rid off them completely?

I want to mention that my autosuggestion options look like this:

enter image description here

So, what else should I delete to remove everything from autosuggestions?

Right now it has some specific URLs (subpages, pages with very specific search query I have made in a month or so).

I have tried restarting Chrome and restarting my computer, but the urls are still in the autosuggestion.

Also I am unable to turn off the autosuggestion, even I have unchecked that option in settings.

My Google Chrome version is: Version 27.0.1453.116 m (probably the latest)

Btw. in Firefox deleting the history works as expected. So, I guess that this has nothing to do with the operating system I am using (Windows 7), but only it's an issue with Chrome itself.

Best Answer

This is a problem I couldn't replicate. I cleared all my browsing history since the beginning of time, and Google Chrome doesn't show any of my previous URLs.

However, you could be having an issue with Google Web History.

enter image description here

You may have to go in and clear your history there. You also probably want to turn it off, it gets pretty annoying.

If that doesn't work, you probably have malware.