Google-chrome – How to prevent a dialog box from opening in Google Chrome

google-chromejavascript

I have to visit a website in a regular basis that reminds me it was originally designed for Internet Explorer 8 and Mozilla Firefox 3.5.12 to 3.6.10. It displays a dialog box with that warning everytime I load the site. I tried reloading Chrome a few times so it'd ask me if I wanted to ignored those warnings but it didn't work.

What can I do to ignore this specific warning? Alternatively, what can I do to ignore any scripted dialog box?

Best Answer

  • To disable JavaScript on a specific site, add it to Chrome's JavaScript exceptions list.

    Chrome JavaScript exceptions list

    Visit this page: chrome://chrome/settings/contentExceptions#javascript > Enter host url > Under Behavior choose Block. Do note, this would also disable all other JavaScript feature on the specified URL.

    Update: See if Better Pop Up Blocker helps.

    Better Pop Up Blocker improves the default Google Chrome pop up blocker by blocking pop up windows opened by javascript & other annoyances that it misses like alert, prompt, and confirm boxes.