Has anyone successfully configured mutt for GMail on FreeBSD? If so, how


I've tried following the instructions here and here. Currently, I can read email from my GMail account, but not send—this is on a personal computer, so even if I configured Sendmail, I doubt any of the mail would survive the spam filter gauntlet. Both guides seem to require the --enable-smtp option for mutt, which I don't think is being exposed by ports. I've tried the mutt and mutt-devel ports and neither seem to give me that option.

On a far less important note, I also haven't been able to change folders, e.g., I get told that Sent Mail is not a valid folder when I attempt to go into it. If you can troubleshoot this problem, it's pure gravy. I really only care about sending.



UPDATE: For those who are interested, the mutt wiki has a GMailOverIMAP UserStory.

UPDATE 2: Although I finally solved my original problem (enabling SMTP support for mutt in FreeBSD), @grawity convinced me to use a relay and avoid mutt's native SMTP support. With that in mind, I went with msmtp. At that point, The Quick-N-Dirty Guide to Using mutt with gmail was very useful, including tips on how to enable OpenSSL for msmtp (so it can talk to GMail's SMTP servers, which use TLS).

Best Answer

I wouldn't use the SMTP support in Mutt. <subjective> It's just not the Unix way. Much better is </subjective> to configure something like esmtp or msmtp or maybe nullmailer to relay email through Gmail's servers, and then let Mutt use the standard /usr/bin/sendmail way of sending messages.