Windows – How to activate sleep states after Windows 10 install

biossleepuefiwindows 10

I have just bought a new PC from a PC Builder, but they disabled all the power savings settings in the BIOS, and I think that affected the ability to use any of the sleep states because that was the state whilst Windows was installing.

I first noticed a problem when I tried to change the power button settings –
I noticed that Sleep was missing:

---- Power and sleep button settings ---

When I Press the power button: Do Nothing
                               Shutdown
                               Turn off the display
When I press the sleep button: Do Nothing
                               Turn off the display

--- Shut-down settings ---
[ ]  Lock
     Show in account picture menu

I tried the "Change Settings that are currently unavailable" option,
but that made no difference.

So I then tried
powercfg /a, which returned the following:

The following sleep states are not available on this system:
Standby (S1)
    The system firmware does not support this standby state.
    The current power policy has disabled this standby state.

Standby (S2)
    The system firmware does not support this standby state.
    The current power policy has disabled this standby state.

Standby (S3)
    The current power policy has disabled this standby state.

Hibernate
    Hibernation has not been enabled.

Standby (S0 Low Power Idle)
    The system firmware does not support this standby state.

Hybrid Sleep
    Standby (S3) is not available.
    Hibernation is not available.

Fast Startup
    Hibernation is not available.

I assumed that the BIOS settings must be disabled and that after enabling them I would see those missing states, but it's still the same.

Someone recommended activating the Hibernate – they thought that would fix it, but all it did is add some rows to the top of the report

The following sleep states are available on this system:
    Hibernate
    Fast Startup

My motherboard is an ASUS Z270-K. 
Does anyone have any suggestions other than a reinstall?

Additional information asked for by Andrew Morton:

  1. Which BIOS is it?
    It is now PRIME Z270-K Version 1207;
    Release Date: 22/06/2018
  1. What Power Settings did you use?
    Ai Tweaker\Internal CPU Power Management
          Intel Speedstep = Auto
          Turbo Model = Enabled
    Advanced\Platform Misc Configuration   PCI Express Native Power Management = Enabled
    Advanced\CPU Power Management Control   Intel Speedstep = Auto   Turbo Model = Enabled   CPU C States = Auto

Update 20:50 11 July 2020 – Found where Sleep States are found in BIOS:

      Advanced\APM Configuration
            ErP Ready = Disabled

ErP Ready Setting is now updated

      Advanced\APM Configuration
            ErP Ready = S4+S5

powercfg -a has not changed with respect to sleep states.  I now have a "The hypervisor does not support this standby state" now that I've enabled virtualization for WSL2 to work.

Update 21:20 11 July 2020 – Found out that S5 means off, so not sure what the point of this is, so setting it back to disabled.

Update 15 July 2020 – On a previous go through of I found information from Microsoft outlining some special setting for enabling the power states: Allow sleep states.

I didn't find it easy to understand, but today I found out how supposedly I could use powercfg with the information found on that page to do it.

So I ran powercfg /setACvalueindex scheme_current SUB_SLEEP ALLOWSTANDBY 1

However this comes back with the message "Group policy override settings exist for this power scheme or power setting."

I have no idea what this means or how to fix it. 
I tried creating a new powerplan and substituting scheme_current
with the GUID of the new plan; however, the same message appears.

Best Answer

  • To disable this you can change the following registry key HKLM\System\CurrentControlSet\Control\Power\CsEnabled (1->0)

    That will remove the S0 setting and enable S3 (verify by running powercfg -a in a command prompt). The problem is that manufacturers like Dell seem to have worked with Microsoft to have drivers rely on S0. They should be ashamed giving users this kind of crap. As a result, when I apply this on my Dell Inspiron 5482 2-in-1 I get a BSOD at wake.

    Dell and Microsoft should be SUED for this mess. There is no BIOS option to enable S3 and while it's perfectly possible on Linux to enable S3 and wake properly, it's not supported in Windows. Not only that, this behavior is a plain DANGER.

    With S0 sleep mode, if the laptop is put in a bag, it will simply overheat. If any hardware precautions against that fail, you might even have a fire hazzard. I read on Lenovo forums that users had this issue too, which was reverted by Lenovo after many user complaints. A laptop is not a smartphone or a tablet and to force it's powermanagement to work like it is plain retarded. Just like forcing a touch interface on a normal screen.

    I recommend EVERYONE to stop buying stuff from vendors that break your hardware, to return it where possible and to push support to fix this issue (by enabling S3 in BIOS, at least as an option). I also recommend to read my post on the Dell forums that describes how to fix this in Ubuntu Linux, which I can recommend anyone that can to use over a shitty proprietary operating system from an arrogant shitty vendor:

    https://www.dell.com/community/Inspiron/Computer-will-not-standby/m-p/7530376/highlight/true#M78091

    Last but not least, I would recommend to have all actions in powermanagement use hibernate instead of sleep, for safety reasons. It's slower, but at least your machine will really sleep and not overheat. Try claiming warranty if your machine is fried, I guess some proper accident has to happen before shitty vendors respond.

  • Related Question