How to allow outdated plugin (e.g. Adobe Flash Player) in Opera 30.0.1835.88 (and earlier)

browser-plugindesktop-computerflash-playeroperaplugins

If you are interested in resolving the same issue in Opera 30.0.1835.125 (or later), please proceed here.

There is a plenty of stone age machines, where the modern versions of Adobe Flash are just unusable, whereas the old ones work acceptable. But by default Opera blocks usage of outdated plugins and forces to update them.

Is there a way to resolve that and continue to use old version of the plugin?

Best Answer

Add --allow-outdated-plugins argument to an Opera launch shortcut like this:

"C:\Program Files\Opera\launcher.exe" --allow-outdated-plugins

Note that starting from version 30.0.1835.125 the browser seems to ignore this key and it blocks usage of outdated plugins anyway. Till there is no way to allow outdated plugins in the new versions, you could disable automatic updates and stay with version 30.0.1835.88 (or earlier).