Firefox – How to block Hot Network Questions in the sidebar of Stack Exchange network


Operating system is Ubuntu 14. Firefox is 50.1.0

This is what I have tried:

enter image description here

I restarted firefox after that. There was no effect.

What is the way to block those hot questions on the sidebar?

Best Answer

That's one of 50 or 60 enhancements to the SE user interface in the Stack Apps add-on SOX. You can load it from that link. You will also need a userscript manager installed for it to work -- Greasemonkey (for Firefox), Tampermonkey (for Chrome), or NinjaKit (for Safari).

To block Hot Network Questions, select the "Hide the Hot Network Questions module" option in the Appearance section of the features menu. The features menu will be accessible from a button added to the topbar:


BTW, another feature allows you to filter what is shown in the HNQ list by site and other attributes. The full list of features can be found here. Many of the enhancements are indispensible.

I would recommend installing the Development Version rather than the Official Version. The Development Version includes new enhancements but more important, it includes the latest bug fixes (and rarely introduces new bugs). SOX is used on a wide variety of platforms, browsers, and configurations, so that's an easy way to avoid a potential problem someone else discovered and has already been fixed.