Google-chrome – How to change the default google account in google chrome

emailgmailgoogle-accountsgoogle-chromegoogle-drive

I've been using Google Chrome on Linux since forever and I use Google products for pretty much everything: mail, calendar, contacts, docs. My company also uses Google for internal apps and I've been happily using both accounts setting the company one as the default one as reported in many how-tos (for example: https://productforums.google.com/forum/#!topic/gmail/4nvMI_r58uQ)

With the following version of chrome:

% google-chrome --version
Google Chrome 69.0.3497.100

I am no longer able to keep the company one as default across Google Chrome restarts. I suspect is related to the fact that I am logged in Chrome with my personal account.

I find this very frustrating because I often have to switch from my personal account to the company one. Is anyone else running into this issue? Does anyone know how to set a default account once and for all?

Please notice that messing around with the URL is not what I want to be doing.

https://mail.google.com/mail/u/0/#inbox    # first account
https://mail.google.com/mail/u/1/#inbox    # second account

EDIT 2020-10-04

Newer version of Chrome definitely broke the default account mechanism. I just switched to separate profiles for work and personal browsing. However, I recently tried brave browser and it shows the behaviour that I miss so much from Chrome. I am now using brave on Android and Linux and I am having a great experience. So, thanks Google Chrome for the time together. Is not you, it's me… goodbye.

EDIT

From some comments it appears that my point is not entirely clear. Notice there two logins here:

  1. Login into Google Apps
  2. Login into Google Chrome Browser for syncing bookmarks, history, etc.

I want to use my personal account for 2. And I want to use my company account as default for 1. I tried to logout of both and then login in the correct order, however, this works only until I restart Chrome.

Once I restart Google Chrome, the default account for 1. is set to my personal one.

Best Answer

Since Chrome 69 any login to a Google app causes an automatic login to the Chrome Browser with the same account.

There has been a strong protest on the Internet, and Google has promised to add an option for it on Chrome 70.

Until Chrome 70 comes out, and as long as this workaround still works, you may open chrome://flags/#account-consistency, find Identity consistency between browser and cookie jar and set to Disabled.