Windows – How to completely disable Touch Screen on Windows 7

touchscreenwindows 7

I have a Dell Precision laptop, and on Windows 7 I've been having trouble with the touch screen. The cursor jumps around the screen when I'm not touching it. I'm not sure if it's a driver issue, or a hardware issue, but it's really annoying. Since I don't use the touch screen anyway, I figured I would just disable it.

So I went into the "Touch" tab in "Pen and Touch" in Control Panel, and unchecked the "Use your finger as an input device" option. This mostly works. However, on the Ctrl-Alt-Delete screen, or when any UAC dialog is displayed, the touch screen works again and as a result the cursor starts jumping around again.

Is there another way to disable the touch screen in Windows 7?

Best Answer

So I found the "Tablet PC Input Service", stopped and disabled it, and the problem seems to have gone away.