How to connect the front audio panel

audiofront-panel

My motherboard is Gigabyte GA-945PL-S3. So due cleanning I had to disconnect front audio panel wires. Then I installed Windows 7 on a new hard drive. But now I don't know how to plug the wires back. Well I plugged how I remember (hope didn't damage it) but Realtek HD Audio Manager can't detect speakers nor microphone at front panel, everything seems to be fine on back panel. This is what manual show:

enter image description here

This is how it was before (that worked – but can't see well)
enter image description here
From front panel comes these wires:
2x GND(black)
Mic Bias(yellow)
Mic in(green)
Left out(red)
Right out(white)

Edit
I have found the problem. It was in Realtek Manager itself. I had to disable "Detect front panel sound".

Best Answer

My motherboard is a Gigabyte GA-H87-HD3 and I was having the same problem of Realtek HD Audio Manager not detecting speakers in the front panel. After trying all kinds of solutions and reading the MB's manual dozens of times, I found out it was simply a matter of checking a checkbox!

Double-click the red speaker in the tray:

enter image description here

It will open Realtek HD Audio Manager. Click the yellow folder icon next to the upper-right corner of the window:

enter image description here

This is the important part. Although it may seem contradictory, you have to check the option that says "Disable front panel jack detection":

enter image description here

Now the front panel icons are enabled:

enter image description here

And now your front panel audio should be working.

If you still have no sound, maybe this more technical answer could enlighten you.