Firefox – How to disable mouse wheel scrolling of Firefox tabs

firefoxmouse-wheel

I'm on a laptop, and my touchpad is multitouch. I'm using Firefox 22.0

By tapping with 2 fingers it can simulate a mouse middle-click.
By scrolling with 2 fingers it will simulate a wheel mouse.
Sometimes it gets these two mixed up and will do both.

To close a Firefox tab, I almost always use middle-click (2 finger tap) on the tab. Though, about 1/4 of the time it quickly scrolls through my tabs and closes the wrong tab. (Who the hell uses mouse wheel on their tabs anyway?)

I don't want to resize my tabs, I have over 100 tabs open at any given time. If possible, I want to disable Firefox from scrolling tabs with the mouse wheel.

Best Answer

I don't see this behavior (scroll wheel scrolls between tabs) on any of my stock Firefox installs.

Perhaps this is added by an extension such as Tab Mix Plus?

If so, you can go to

  • Tab Mix Plus options
  • Mouse
  • Mouse Gestures tab
  • Uncheck "allow scrolling to select tab"

(source: http://forums.mozillazine.org/viewtopic.php?f=38&t=1736255 )