How to enable click-to-play functionality for HTML5 media in Vivaldi

browservivaldi

I've already tried:

  • Going to vivaldi://settings/content and enabling Content Settings → Let me choose when to run plugin content
  • Going to vivaldi://plugins and unchecking 'Always allowed to run' for Widevine Content Decryption Module (Enables Widevine licenses for playback of HTML audio/video content)
  • Installing the Disable HTML5 Autoplay browser extension

…but to no avail.

When I go to youtube.com or any site with HTML5 media, the HTML5 media still immediately appears with no click-to-play functionality.

I am using Vivaldi 1.3.551.30 (Stable channel) (64-bit) on Windows 7. I've disabled Flash at vivaldi://plugins.

Best Answer

I found this page helpful.
https://help.vivaldi.com/article/html5-proprietary-media-on-linux/

This is putting the libffmpeg.so file that Vivaldi is looking for into the directory where Vivaldi can find it.

Don't forget to restart Vivaldi afterwards.

Other Linux (Including Ubuntu 14.04)
64-bit

curl -L vvld.in/lm64|tail -c+1079|tar xJ -C ~ --wildcards \*libffmpeg\.so --xform 's,.*/,.local/lib/vivaldi/,'

32-bit

curl -L vvld.in/lm32|tail -c+1077|tar xJ -C ~ --wildcards \*libffmpeg\.so --xform 's,.*/,.local/lib/vivaldi/,'

32-bit (Arm)

curl -L vvld.in/lm32a|tail -c+1079|tar xJ -C ~ --wildcards \*libffmpeg\.so --xform 's,.*/,.local/lib/vivaldi/,'

64-bit (Arm)

curl -L vvld.in/lm64a|tail -c+1077|tar xJ -C ~ --wildcards \*libffmpeg\.so --xform 's,.*/,.local/lib/vivaldi/,'

Testing
You can then test video support on this page and audio support on this page.