Google-chrome – How to get 5.1 audio in Google Chrome

audiogoogle-chromespeakersstereosurround-sound

I'm using Windows 7 and my speaker configuration is surround (5.1). I don't have any problem with games or my MP3 player. Games have surround output and it works perfect. MP3 player's output is stereo and my sound driver (creative) fills up the stereo to surround so it's perfect too. My only problem is with Chrome + YouTube + Html player. I can't hear the music from the rear speakers on Chrome.

I tried many things including chrome.exe --disable-audio-output-resampler switch for Chrome but nothing helped. Chrome's output is surround unlike my MP3 player. So the Creative sound driver can't fill it up to surround because it's already surround. YouTube videos don't have surround channels. They only have stereo channel. In this case, Chrome plays the video sound on first 2 channels. The other channels (3.1) are empty. Creative can't fill up the first 2 channels to 5.1 because it doesn't work on applications with surround output. It only works on stereo output.

So I've come up with an idea. If I can fool the Chrome to think that my speaker configuration is stereo (even if it's 5.1 physically), it would set it's output as stereo so my Creative driver could work on Chrome to fill its output to surround.

Does anybody know if I can fool a specific application (Chrome in this case) to believe I have stereo speaker configuration?

Best Answer

Update: [As of Jan 13 - 2020] Now this option is GONE and the feature appears to be active by default (since version: 79.0.3945.117)
So nothing needs to be done. You can verify with a true 5.1 audio file played through the browser. https://www2.iis.fraunhofer.de/AAC/multichannel.html

In order to up-mix stereo signal into a multichannel audio - you need to look into the options of your sound-card driver instead.

I use the old Creative X-Fi MB3 software to do that for me.

[Previously i.e. before Chrome 79]
Go to chrome://flags and enable #try-supported-channel-layouts flag; relaunch.

chrome://flags/#try-supported-channel-layouts

This way it worked. Chrome::Youtube surround sound on my 5.1 speakers finally!

I could not get it working via the command line options. And perhaps the other command line options are now deprecated. Generally too, I recommend using the flags instead of the command line params