Windows – How to make explorer in Vista remember a folder’s view

windows-explorerwindows-vista

For no apparent rhyme or reason Vista will decide to show a folder that was previously in details view to start showing thumbnails. I go to the folder and right-click, Customize, and set it the template to "All Items", and "Also apply this template to all sub-folders", but it some point it will again decide to display it as thumbnails. Is there a way to force this setting to stay, or is it that possibly something is changing it that I am not aware of?

Best Answer

There seems to be multiple things that might cause this as an issue, and multiple resolutions as well, hopefully solving or making this "bug" appear less frequently.

  1. Manually resetting the folder view cache/settings
    1. Start regedit. (Win+R, enter regedit, press Enter or click OK. )
    2. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell.
    3. Delete the keys Bags and BagMRU.
    4. Browse to HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell, repeat step 3.
    5. Browse to HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam, repeat step 3.

Trying some of these additional tweaks might help, mix it with it and see what you get.

  • Disabling automatic folder type discovery
    1. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell in regedit.
    2. Create a new key under Shell, called Bags.
    3. Create a new key under Bags, called AllFolders.
    4. Create a new key under AllFolders, called Shell.
    5. Create a new string value under Shell, called FolderType.
    6. Set the string value of FolderType to NotSpecified.

You can increase the size of the folder view cache as well.

  • Increasing the size of the folder view cache

    1. Browse to HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell.
    2. Set the DWORD value of BagMRU size to something higher than 5000.
      • Note: If it's not there, create it.
  • After resetting the cache/settings + apply tweaks

    1. Log off/on or reboot.
    2. Open a Windows Explorer window and go to the Folder Options window.
      1. Select the View tab.
      2. Check Remember each folder's view settings.
      3. Uncheck Restore previous folder windows at logon.
      4. Hit the OK!

This should do it, or rather, perhaps improve the experience. Nevertheless, using an application as CCleaner with the wrong settings can disrupt and delete your settings, so be aware and checking before you use applications focused on "cleaning up".