Windows – How to send VLC Player audio to headphones rather than PC speaker

audioaudio-outputvlc-media-playerwindows 7windows media player

Similar to this question, except I'm on Windows 7. That question also has no accepted answer, and the answer doesn't work for me.

I've tried all the different "Output Module" settings in the Audio section of the preferences in VLC Player, and still the sound comes out of my PC speaker instead of the 3.5mm audio jack, where my headphones are plugged in.

Headphone audio output works fine for every other application I've used, including Windows Media Player.

How can I get VLC Player to send its audio output to my headphones instead of to the PC speaker?

Best Answer

  • This solution (from here) resolved the issue:

    1. Open Tools/Preferences and at the bottom of the list,under "Show settings" switch from Simple to "All".
    2. Under Audio, Expand and select "Output module" and change Audio output module to "Win32 waveOut extension output".
    3. Under "Output module" select "Waveout".
    4. Select Audio Device. In the dropdown, select your output used for your headset and click save.
    5. Restart VLC.

    Note that in my case the restart of the VLC application was definitely required! It may also mean that when I previously tried various different settings without restarting VLC, the changes may actually have worked after restarting VLC.