Internet Explorer defaults to 64-bit version

internet explorer

My IE8 has suddenly started defaulting to the 64-bit version. I have no idea how or why this has happened, but I suspect it might be linked to the Browser Choice Screen that Microsoft was recently forced to display by EU law.

However, many web sites will not display correctly in IE8 x64 (eg. sites that use Adobe Flash or Microsoft Silverlight). I have the 32-bit version of IE pinned to my taskbar and if I launch it manually, everything is fine. But when I click on a URL from another program and IE is not already running, then the 64-bit version gets launched. This really messes with programs like BBC iPlayer which rely heavily on Adbobe Air and Flash.

So, how do I get IE8 32-bit version to be the default version again? I've tried using the "default programs" control panel and that doesn;t make any difference (in fact, it doesn't give the choice between x84 and x64 versions, it just lists "internet explorer").

Best Answer

Try editing the registry. Make sure to open the 64-bit registry editor. (you have to close the 32-bit one first).

Go to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Classes\http\shell\open\command and set the (Default) value to the path (from the 64-bit point of view) of 32-bit IE, which might be "C:\Program Files(x86)\Internet Explorer\IEXPLORE.EXE" -nohome (the "-nohome" is a commandline option which my copy of IE8 adds to this value)

You might want to do the same for the classes https and even htmlfile if you want to double-click HTML files and open them in 32-bit IE.

All this won't help if a 64-bit application executes iexplore.exe directly instead of launching a URL. (in fact I haven't tested my suggestion at all because I don't have 64-bit Windows. Nevertheless it might work)

Related Question