Windows – is “run this program as an administrator” disabled

administratorbatchserviceswindows

I need to stop some services so I made a cmd file but it doesn't work because it needs to run as admin.
When I right click on the file and choose Properties, I see that "run this program as an administrator" is disabled. Why? How do I turn it on?

The UAC is enabled (but set not to dim the screen) and for other programs (exe files) that box is enabled.

Best Answer

  • As a workaround you can try this.

    Create a shortcut to the batch file
    Right-click on the shortcut and select properties
    (Ignore the option on the compatability tab which is still disabled)
    Select the Shortcut tab
    Click on Advanced
    Select 'Run As administrator'
    Click on Ok

  • Related Question