Is there a way to avoid “Guru Meditation” when doing docker pull

dockermemoryvirtualbox

I have Win 7 32-bit, Vagrant + Virtualbox. I spin up a Ubuntu 14.04 VM (4cpu and 1.5G RAM) and install docker. Then, I execute a

docker pull jenkins

RAM use on the VM zooms to nearly 100%, and eventually the VM goes into some mode Virtualbox calls "Guru Meditation".

Jumping through a few hoops, I shut down the VM, relaunch and pull again, and this usually completes. Then I launch the jenkins container and after chugging along at 80% CPU for several minutes, "Guru Meditation", again!

I'm not sure of this behavior is typical of docker or if this is specific to the jenkins image. How would I be able to tell?

Is there a way to limit docker resource usage? I don't see anything in the docker daemon options docs.

Any other tips for avoiding "Guru Meditation"?

Best Answer

  • First You should look for any errors in vbox.log. If it's a memory problem you should be able to fix this by changing the memory allocated to your guest OS. Take a look at this post on the problem: http://www.fixedbyvonnie.com/2014/09/heck-virtualbox-guru-meditation-error/

    But definitely look in the error log first ...

  • Related Question