Linux – black backgrounds appear grey on gnome-terminal

colorsgnome-terminallinux

Running gnome under Ubuntu Lucid

$ env | grep TERM
TERM=xterm
COLORTERM=gnome-terminal

I had to edit both my .muttrc and my vim colorscheme to change the background color from black to none in order to get a proper black background (or, more accurately, to retain the terminal's default black background). Setting it to black resulted in a dark grey background. This only happens with gnome-terminal; konsole, xterm and rxvt are fine.

Best Answer

I found a solution to this. I'm now using GNOME Terminal 2.32.0 and it still has the same problem. I fixed it by changing the color pallete. From the Edit menu, select Profile Preferences, then the Colors tab. Click on the upper left rectangle in the Color pallete, Palette entry 1. This has a default Color name of #2E3436. Change this to #000000. Voila!