Linux – CentOS: installing a GD Library

centoslinuxPHP

I'm running PHP version 5.3.5.

Now I need to install GD Library.

When I run: –> yum info php-gd, it says Missing php-common 5.1.6-43.el5_10.

php-gd-5.1.6-43.el5_10.x86_64 from updates has depsolving problems
–> Missing Dependency: php-common = 5.1.6-43.el5_10 is needed by package php-gd-5.1.6-43.el5_10.x86_64 (updates)
Error: Missing Dependency: php-common = 5.1.6-43.el5_10 is needed by package php-gd-5.1.6-43.el5_10.x86_64 (updates)

php-common-5.3.5-1.el5.remi.1 is already installed in my server. I cannot verify why php-gd is depending on php-common-5.1.6.

How can I install GD library 5.3.5 in server without having to do upgrading to php version?

Thanks & Regards,
Nge

Best Answer

What you are looking for, when you use the CentOS repositories, is php53-gd, not php-gd.

That said, it sounds like you have installed PHP 5.3 from another repo, so you'll likely want to make sure you're trying to install that repo's equivalent of php53-gd.

EDIT: Or make sure you're enabling that repo when you try to install the package.