Linux – Cinnamon Text / Icons disappearing

cinnamondebianlinux

Two of our Linux clients are running Debian 8.5 with the Cinnamon DE.

This Problem seems to only occur on the Cinnamon DE.

Randomly the text and icons in the panel just disappear. The system keeps running.

Many people say its related to the Intel Graphics Chip, others say they have the same problem using nVidia Harware.
Some people also say its related to Qt5 applications.


Looks like this, but sometimes its even worse and the application icons disappear too:
enter image description here

(Dont wonder about the ArchLinux and Linux Mint wallpaper, got these pictures from the Internet)

The strange thing is, me myself also have Debian 8.5 with Cinnamon and never had this problem.

I've tried following things:

Change Font scaling factor

gsettings set org.cinnamon.desktop.interface text-scaling-factor 1.1
gsettings set org.cinnamon.desktop.interface text-scaling-factor 1

Reset GTK-Theme

gsettings set org.cinnamon.desktop.interface gtk-theme temp
gsettings set org.cinnamon.desktop.interface gtk-theme yourTheme

Reset Icon Theme

gsettings set org.cinnamon.desktop.interface icon-theme temp
gsettings set org.cinnamon.desktop.interface icon-theme yourIconTheme

Reset Interface scaling Factor

gsettings set org.cinnamon.desktop.interface scaling-factor 2
gsettings set org.cinnamon.desktop.interface scaling-factor 1

also i tried changing the Font Anti Aliasing settings to Greyscale

Last dmesg output:

[  549.742718] perf interrupt took too long (2506 > 2500), lowering kernel.perf_event_max_sample_rate to 50000
[ 1021.500683] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 60
[ 1021.500688] Raw EDID:
[ 1021.500691]      00 ff ff ff ff ff ff 00 1a b3 d0 07 01 00 00 00
[ 1021.500692]      32 14 01 03 80 2f 1e 78 2a 36 c5 a4 55 4c 9c 25
[ 1021.500693]      12 50 54 a5 4b 00 95 00 95 0f 81 00 81 0f 81 c0
[ 1021.500695]      81 80 b3 00 01 01 21 39 90 30 62 1a 27 40 68 b0
[ 1021.500696]      36 00 da 28 11 00 00 1c 7c 2e 90 a0 60 1a 1e 40
[ 1021.500697]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1021.500698]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 1021.500699]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4739.213325] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 82
[ 4739.213330] Raw EDID:
[ 4739.213332]      00 ff ff ff ff ff ff 00 1a b3 d0 07 01 00 00 00
[ 4739.213333]      32 14 01 03 80 2f 1e 78 2a 36 c5 a4 55 4c 9c 25
[ 4739.213334]      12 50 54 a5 4b 00 95 00 95 0f 81 00 81 0f 81 c0
[ 4739.213335]      81 80 b3 00 01 01 21 39 ff ff ff ff ff ff ff ff
[ 4739.213336]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4739.213337]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4739.213338]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 4739.213338]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6658.193659] perf interrupt took too long (5142 > 5000), lowering kernel.perf_event_max_sample_rate to 25000
[ 6752.791942] [drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 100
[ 6752.791949] Raw EDID:
[ 6752.791952]      00 ff ff ff ff ff ff 00 1a b3 d0 07 01 00 00 00
[ 6752.791955]      32 14 01 03 80 2f 1e 78 2a 36 c5 a4 55 4c 9c 25
[ 6752.791957]      12 50 54 a5 4b 00 95 00 95 0f 81 ff ff ff ff ff
[ 6752.791959]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6752.791961]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6752.791963]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6752.791965]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
[ 6752.791967]      ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff

journalctl is saying the same, I dont know if this output is anyhow problem related but maybe someone knows what this exacly means.

There are things I still did not try because someone is working on the Client right now and I don't want to interrupt him working, I will try following things as soon as he goes home.

Creating a /etc/X11/xorg.conf with:

Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
EndSection

Turning of "Software Compositing" in "Window Preferences"

and Installing a other version of the Intel Graphics Driver

Known Workaround:

I've read alot of forum posts already, all of them saying to restart the xserver or to restart cinnamon:

  1. Press Alt + F2
  2. Type "r"
  3. Press Enter

If you only have a Terminal to access (for example your system froze completely and you can only access tty), try typing:

cinnamon --replace

All the things i tried above seem to work for some other people, so if you have the same Bug you should atleast try them.

However this is only a workaround and really annoying to do for non-linux Users. The problem occures around 5 Times a day sometimes even more often.

Any help is appreciated.

Best Answer

  • I had the same problem on three computers, different hardware. All three however use intel integrated graphics. I found solution on an ubuntu forums, marked as an old bug and thought I can share it here - I was here before searching for solution. https://askubuntu.com/questions/584922/how-do-i-fix-fonts-not-rendering-and-missing-letters Qutoe nailing the problem:

    Then, went to Fonts, changed Antialiasing option from Subpixels Antialiasing (LCD screens only) to Standard Grayscale Aliasing and everything seems to work fine. Infact, the problem immediately appears/disappears on changing the setting, so seems this is indeed the cause.

    In mint I switched from RGBA to grayscale. Same problem occured on those computers using ubuntu 16.04, mint 17 and 18. Now it's okay - almost a week and no problem. Regards

  • Related Question