Linux – Disable kde screen scaling for specific applications

debiandisplaykdekde-plasma-5linux

4.9.0-2-amd64 #1 SMP Debian 4.9.18-1 (2017-03-30) x86_64 GNU/Linux
kde-plasma-desktop                            5:92

This is my problem, I have a high density display so I need to scale my screen to 1.5 to make it usable.

This is screen scaling feature to which I am referring:
enter image description here

But I also use Android AVDs which don't respond well to the screen scaling (see my post about this issue)

So what do I do about apps that break when the screen is scaled? Can I disable scaling for a specific application?

Best Answer

  • Run QT_SCALE_FACTOR=1 to disable scaling for that application.

    Example: QT_SCALE_FACTOR=1 emulator -avd n5 -verbose

    Alternatively, you may consider reverting the scaling, then starting other applications with QT_SCALE_FACTOR=1.5.

    High DPI Displays | QT 5.8

    QT_SCALE_FACTOR [numeric] defines a global scale factor for the whole application, including point sized fonts.

  • Related Question