Linux – How to change terminal font size in i3 on arch linux

arch linuxfontsterminal

I installed xorg, I can successfully startx and I installed i3 on arch linux. How can can I change, or more specifically; increase the size, in the default terminal in i3? From the i3wm documentation it states I can do the following: font pango:Terminus 11px but that results in a font: command not found error. I hope someone can guide me in the right direction.

** EDIT **

I was able to change the font and font size but the font is still small. I am on a 13" laptop with a high-res screen. Also, arch linux is installed on a virtualbox. Guest additions were installed and work. I created ~/.Xresources file with the following

xterm*faceName: dina-font
xterm*fontSize: 20

I also edited my ~/.xinitrc file with

xrdb -load /home/username/.Xresources & 
exec i3

When I start X, i3 load with the settings from ~/.Xresources: dina-font (Monospace) and size 20. However it is still small.

When I increase the size using the xterm*fontSize setting or Ctrl + Right click, only the cursor block gets bigger but the actual font does not. Perhaps this is a screen resolution at this point?

Best Answer

It's not fully clear if you want to change the font in your terminal (are you using xterm?) or in your vconsole before issuing startx command.

To change the font size in xterm:

xterm*faceSize: 23