Linux – How to stop adding IP from EC2 to known_hosts for ssh

amazon ec2linuxopensshssh

I start/stop lots of new instances as I'm learning to use Amazon EC2. Every temporary instance is added to the known_hosts file. Is this ever a problem for others who use EC2 a lot?

I'd like to tell ssh to skip this step anytime I connect to amazonaws.com. Is there a way to do that in the config? I'm using Linux & openssh.

Best Answer

This is done to prevent Man in the Middle attacks. Disabling it would disable basic functionality of the ssh tools.

You may want to keep a copy of your .ssh/known_hosts file without the entries and replace it when you are done.