Linux – Installing Ubuntu or Mint from behind a proxy

installationlinux-mintUbuntu

Whenever I install Ubuntu or Mint from behind a proxy, I find that the installation hangs during the timezone configuration phase. Figuring that it had to be related to the network, I restarted the install and selected "Try Ubuntu" instead of "Install Ubuntu". This boots me into a gnome-shell.

From there I updated the proxy settings to the values appropriate for my network and clicked on the "Ubuntu Install" icon on the desktop. The install still stalls around the "Copying Files" phase, grrrr.

Using a terminal, I can verify that the environment variables are correctly set to the proxy values, however, when I examine the environ file in the /proc/pid entry for the installer process, these proxy variables are not set.

Therein lies the problem, the installer is almost certainly invoked using the old environment variables and consequently, never gets to see the proxy settings.

I suspect the issue would be resolved if I could log out and log back in again, forcing the gnome-shell to reload but that isn't an option as the Ubuntu live configuration does not allow you to do this. I've got a workaround which I'm going to post here for others but any additional insight or more elegant solutions are welcomed.

Best Answer

The logging using the suggested solution showed lots of errors in dealing with filesystem, etc.. Installation hangs for very long periods of time and never finishes. I think the problems occur because ubiquity is trying to run as user. I am installing Linux Mint 16 Cinnamon edition (64 bit). The system previously had a Cent OpenStack system with LVM installed on it.

I found another approach that worked flawlessly. It requires you to elevate into root before you run ubiquity. But you must also provide the required proxy environment variables....

Boot the Mint CD to the trial desktop...

  1. Set manual proxy in the system settings, set whatever proxy settings you need for your networking environment.

  2. Start terminal.

  3. Enter the command:

    sudo -E bash

  4. Now you are in a root session with the environment inherited from the user session (-E option did this for you)

  5. Now at the command prompt enter:

    ubiquity gtk_ui

Ubuiquity runs as root and the install went perfectly with no problems at all. Only took a couple of minutes to complete. !!